Filters and Folder Properties don't work

  • 4 Replies
  • 4719 Views
*

Offline bushtick

  • Noctule
  • **
  • 12
Filters and Folder Properties don't work
« on: March 16, 2009, 12:19:17 PM »
 :oops:
I really would like to get the reputedly powerful filters of The Bat! working for me but have found that the only filter I have tried, to move anything from a specified email address to a specified folder when it is over 1 day old, does not work.

Also tried to set properties for a specific folder, so that the max number of emails in it was 30 and to keep messages in the folder for a maximum of 30 days. There should be no conflict here since the folder concerned is for a news feed I get every day.

What am I doing wrong?

*

Offline Anne

  • Administrator
  • Golden Crowned
  • *****
  • 1193
  • Gender: Female
  • Rabbit Lady
    • Yobunny Enterprises
  • The Bat! version: 6.8.8
Re: Filters and Folder Properties don't work
« Reply #1 on: March 17, 2009, 12:53:05 AM »
Can you post a copy of the filter you're using here please so we can see what you've set up?

Cheers!
Anne


*

Offline bushtick

  • Noctule
  • **
  • 12
Re: Filters and Folder Properties don't work
« Reply #2 on: March 18, 2009, 08:25:48 AM »
Thanks Anne - 3 files attached.  Two to show the filter that is not working and one to show the folder property that is not working

*

Offline Anne

  • Administrator
  • Golden Crowned
  • *****
  • 1193
  • Gender: Female
  • Rabbit Lady
    • Yobunny Enterprises
  • The Bat! version: 6.8.8
Re: Filters and Folder Properties don't work
« Reply #3 on: March 24, 2009, 01:13:14 PM »
Sorry for the delay in replying, I've been tied up for a few days so not been online...

Now let's have a look at your problem. I'll look at the folder setting first, and as far as I can see that should work fine. (I've just used the same setting on one of my folders -albeit under TB! v3 - and it does what it's supposed to. I think you're using v4 though are you?)  Did you set the folder settings after there was mail in the folder?   If you go to the Folder menu > Maintenance centre and use the Purge command on that folder (be careful to make sure only that folder is selected or you'll lose other mail!) do the older emails disappear?

Re the Sorting Filter - sometimes there's a conflict with another filter that stops it working, but you only have two so that should make it easier to diagnose!  What may be relevant is that it's the second of the two filters - filters are always applied in the order they appear in that list from the top downwards. So your Known filter is being applied first, followed by the ZW News one, try moving it up above the Known filter and see if it works then.

Let me know how you get on. :)
Cheers!
Anne


*

Offline bushtick

  • Noctule
  • **
  • 12
Re: Filters and Folder Properties don't work
« Reply #4 on: March 24, 2009, 04:18:53 PM »
Thanks Anne - I have tried that and it seems to work when the filter is applied manually.  Will let you know if the automatic filtering works. Also recreated the ZIM News folder under a slightly different name and put only one condition there (number of messages), then copied more than that number into the folder and it seemed to work.  Time will tell.  Thanks again.

 

SMF spam blocked by CleanTalk