smtp auth problems...

  • 4 Replies
  • 2424 Views
*

Offline PsionicWiz

  • Pipistrelle
  • *
  • 5
    • http://www.xtremecomp.ca
smtp auth problems...
« on: December 05, 2002, 08:00:05 AM »
Im having problem with SMTP auth...

My server is rejecting authentication...
using plain text, same as pop3 login and pass.
 12/5/2002, 00:50:07: SEND  - connected to SMTP server
 12/5/2002, 00:50:07: SEND  - authenticating (software CRAM-MD5)...
 12/5/2002, 00:50:10: SEND  - WARNING: authentication failed
 12/5/2002, 00:50:10: SEND  - sending message to cguilbault@shaw.ca
 12/5/2002, 00:50:10: SEND  - The last address submitted was <cguilbault@shaw.ca>
!12/5/2002, 00:50:10: SEND  - Message has not been sent. Server reply - 5.7.1 Relaying to <cguilbault@shaw.ca> denied (authentication required)
 12/5/2002, 00:50:10: SEND  - connection finished - 0 messages sent
 12/5/2002, 00:50:10: SEND  - Some messages were not sent - check the log for details

In the bat settings I choose connection set to regular, perform smtp auth selected and use setting of mail retrieval... Mail retrieval is set to regular, yet according to the logs it's trying to authenticate using MD5 or am i reading the log wrong?

It works fine using uh Outlook express... any ideas?

Thanks for any help provided

*

Offline Anne

  • Administrator
  • Golden Crowned
  • *****
  • 1193
  • Gender: Female
  • Rabbit Lady
    • Yobunny Enterprises
  • The Bat! version: 6.8.8
SMTP auth problem
« Reply #1 on: December 06, 2002, 02:39:20 AM »
There was recently a discussion of this self-same problem on The Bat! Users Discussion List (TBUDL).  The general consensus from that discussion was that this appears to be a mail server setting - i.e. on the ISP mail server, not in The Bat! therefore the only way to find out why it happens would be to talk with your ISP tech support/mail sysadmin.  

If your ISP uses qmail then the TBUDL discussion will definitely be of interest.  You can read the archived thread here
http://www.mail-archive.com/tbudl@thebat.dutaint.com/msg50341.html
Cheers!
Anne


*

Offline PsionicWiz

  • Pipistrelle
  • *
  • 5
    • http://www.xtremecomp.ca
smtp auth problems...
« Reply #2 on: December 06, 2002, 07:41:43 AM »
WEll it turns out im the isp.... :)
Im using Kerio mail server,
It supports
Plain
Login
Digest-MD5
CRAM-MD5

I was able to find a work around, but it is only valid through my LAN, so this means I will not be able to use BAT outside my network... I set my server to not required AUTH on LAN ip specified segment. Although this does not fix my problem it's a work around that solves it

*

Offline Anne

  • Administrator
  • Golden Crowned
  • *****
  • 1193
  • Gender: Female
  • Rabbit Lady
    • Yobunny Enterprises
  • The Bat! version: 6.8.8
SMTP Auth Problem
« Reply #3 on: December 07, 2002, 12:47:42 AM »
Aaaahhhhh so your server will support CRAM-MD5 but you've not told TB! to use it, but it is still doing so?

This is what TB! does - if a mail server says it can handle CRAM-MD5 but TB! settings are to use regular, TB! actually sets itself to the CRAM-MD5 setting as this is more secure.  In other words TB! is smart enough to always set the SMTP authentication to the most secure method available on the server you'reconnecting to.

If you check TB! help files under SMTP Authentication is says this:

Quote
Once connected to an SMTP server, The Bat! checks which of the server's RFC-2554-authentication mechanisms is available, and chooses the most secure. Even when "Require secure (MD5) authentication" is off, if the server does supports it, secure authentication will take place.


So The Bat! is actually working as it was designed to do.  You can alter the smtp settings for each account in the Account Properties on the Transport tab, then at the top under the Send Mail section there is an Authentication button - try setting the account to Require secure (MD5) authentication and see if that solves the problem.  

Let us know how you get on. :)
Cheers!
Anne


*

Offline PsionicWiz

  • Pipistrelle
  • *
  • 5
    • http://www.xtremecomp.ca
smtp auth problems...
« Reply #4 on: December 10, 2002, 11:01:23 PM »
Thanks for the idea... I did try that and it still does not work I am getting the same errors.

I simply enabled relay from local lan on my server
that seems to work

 

SMF spam blocked by CleanTalk