The Unofficial Bat Support Forums provides help and support for all previous versions of The Bat! before the current version

Author Topic: Quote line spacing  (Read 5958 times)

Offline DOOJ

  • Pipistrelle
  • *
  • Posts: 2
Quote line spacing
« on: October 26, 2004, 02:05:38 PM »
I did a search but didn't find anything on this.

If my original message looks like this:

[code:1]line1
line2
line2

line4[/code:1]

replying looks like this:

[code:1]line1

line2

line3




line4[/code:1]
Basically it's adding a line space, or four lines spaces if I make just one. This increases after a few exchanges of email, so that 1 line space becomes 4, and that 4 line spaces becomes 8 line spaces etc etc. You can imagine how massive an email becomes unless I manually delete the line spaces. Very tedious.

My reply template is currently:
[code:1]--------- Original Message %ODateEn, %OTimeLongEn: ---------
%QUOTES
%QUOTESTYLE="NONE"[/code:1]

How do I stop the line spacing?
Thanks.

Offline Anne

  • Administrator
  • Golden Crowned
  • *****
  • Posts: 1193
  • Gender: Female
  • Rabbit Lady
    • Yobunny Enterprises
  • The Bat! version: 6.8.8
Quote line spacing
« Reply #1 on: October 26, 2004, 10:34:40 PM »
I suspect this is being caused by line wrap length - when you reply the quoted prefix is added to each line making them longer so I think what you're seeing is the line wrapping to an empty new line, and each time it is quoted the line gets longer.

So, my suggestion would be to make you line wrap length shorter... I have my wrap set at 70 characters, with a quote prefix of 5 characters max, and I don't have the problem you're describing. Perhaps changing your setting to the same will resolve things..

To change your line wrap and quote length go to Options > Preferences > Viewer/Editor  > Editor Preferences and look at the top of the tab where it says General Preferences.  Set Wrap Text At ... to 70, and set Quote Name Limit ... to 5, also ensure the box alongside Smart Wrapping of Quoted Text is ticked.

Let us know if this solves the problem for you. :)
Cheers!
Anne


Offline DOOJ

  • Pipistrelle
  • *
  • Posts: 2
Quote line spacing
« Reply #2 on: October 27, 2004, 01:15:05 AM »
Nope didn't work I'm afraid.
The email I sent and recieved looks like this:
http://www.asrm76.dsl.pipex.com/emailtest2.gif
I click reply, and then it looks like this:
http://www.asrm76.dsl.pipex.com/emailtest1.gif

As you can see, it's still adding an extra line where I've pressed enter to start a new line, and the line space doubles with each reply still. :|
I'm wondering if this a weird HTML thing. Pressing ENTER in HTML creates a new paragraph using <p>. SHIFT ENTER creates just a new line <br>, which is what I want.
Is reply adding more HTML tags or something?
Don't know if anyone know where I'm going with this.
Thanks for the continued help though.[/b]

Offline Anne

  • Administrator
  • Golden Crowned
  • *****
  • Posts: 1193
  • Gender: Female
  • Rabbit Lady
    • Yobunny Enterprises
  • The Bat! version: 6.8.8
Quote line spacing
« Reply #3 on: November 03, 2004, 06:06:45 PM »
Can you post me a copy of your reply template? I'm wondering if this could where the problem lies. (Use PM if you prefer.) Thanks!
Cheers!
Anne


 

SMF spam blocked by CleanTalk