The Unofficial Bat Support Forums provides help and support for all previous versions of The Bat! before the current version

Author Topic: Security issue  (Read 3545 times)

Offline davidc

  • Vampire
  • *****
  • Posts: 169
  • Gender: Male
  • ProtoBat
Security issue
« on: February 24, 2006, 09:58:36 PM »
It looks like we need to update to 3.71.03.
Copied from Batworld (sort of)

"The Mailprogramm TB is susceptible in the no longer completely crack-fresh version 3.60.07 and previous to a buffer overflow, which aggressors could use by excessive lines for reference text in emails. Of the Russian NSA Group discovered error steps to the appearance, if a line for reference text contains 4038 characters. By an insufficient length examination when copying into a target buffer it can come to the overflow; Aggressors could transfer code in such a way. Users of an older TB version should  up-date to TB 3.71.03 ."

Basically a buffer overflow.

 

SMF spam blocked by CleanTalk